Welcome

>>>Welcome to my "CODE BAZAR"
Code marshal
URI online judge
Others
Code marshal
URI online judge
Others
Code marshal
URI online judge
Others

Update ✔✔✔ Upcoming programming book (.pdf) "Programming Contest (data structures and algorithms) by Md. Mahbub Hasan & "Graph Algorithms" by Safayat Asraf "****** Date: 20 March, 2019****Hazrat Ali****

Monday, 14 November 2016

URI-1046

URI Online Judge | 1046

Game Time

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Problem link Click here
Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”

Input

Two integer numbers representing the start and end time of a game.

Output

Print the duration of the game as in the sample output.
Input SampleOutput Sample
16 2O JOGO DUROU 10 HORA(S)
0 0O JOGO DUROU 24 HORA(S)
2 16O JOGO DUROU 14 HORA(S)

Solution...

#include <stdio.h>

int main()
{
    int st, et, rt;
    scanf("%d %d", &st, &et);
    rt = et - st;
    if (rt < 0){
        rt = 24 + (et - st);
    }
    if (st == et){
        printf("O JOGO DUROU 24 HORA(S)\n");
    }
    else{
        printf("O JOGO DUROU %d HORA(S)\n", rt);
    }
    return 0;
}

No comments:

Post a Comment