Welcome

>>>Welcome to my "CODE BAZAR"
Code marshal
URI online judge
Others
Code marshal
URI online judge
Others
Code marshal
URI online judge
Others

Update ✔✔✔ Upcoming programming book (.pdf) "Programming Contest (data structures and algorithms) by Md. Mahbub Hasan & "Graph Algorithms" by Safayat Asraf "****** Date: 20 March, 2019****Hazrat Ali****

Sunday, 13 November 2016

URI-1041

URI Online Judge | 1041

Coordinates of a Point

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Problem link Click here
Write an algorithm that reads two floating values (x and y), which should represent the coordinates of a point in a plane. Next, determine which quadrant the point belongs, or if you are over one of the Cartesian axes or the origin (x = y = 0).
If the point is at the origin, write the message "Origem".
If the point is over X axis write "Eixo X", else if the point is over Y axis write "Eixo Y".

Input

The input contains the coordinates of a point.

Output

The output should display the quadrant in which the point is.
Input SampleOutput Sample
4.5 -2.2Q4
0.1 0.1Q1
0.0 0.0Origem

Solutin...

#include <stdio.h>
int main()
{
    double x, y;
    scanf("%lf %lf", &x, &y);
    if (x == 0.0 && y == 0.0){
        printf("Origem\n");
    }
    else if (x == 0.0 && y != 0.0){
        printf("Eixo Y\n");
    }
    else if (y == 0.0 && x != 0.0){
        printf("Eixo X\n");
    }
    else if (x > 0.0){
        if (y > 0.0){
            printf("Q1\n");
        }
        else printf("Q4\n");
    }
    else if (y > 0.0){
        printf("Q2\n");
    }
    else printf("Q3\n");
    return 0;
}



No comments:

Post a Comment