Problem link Click here
Make a program that reads 3 integer values and present the greatest one followed by the message "eh o maior". Use the following formula:
Input
The input file contains 3 integer values.
Output
Print the greatest of these three values followed by a space and the message “eh o maior”.
Input Samples | Output Samples |
7 14 106 | 106 eh o maior |
217 14 6 | 217 eh o maior |
Solution....
#include<stdio.h>
int main(){
int a,b,c,ab,abc;
scanf("%d %d %d",&a,&b,&c);
ab=(a+b+abs(a-b))/2;
abc=(ab+c+abs(ab-c))/2;
printf("%d eh o maior\n",abc);
return 0;
}
No comments:
Post a Comment